Si estás teniendo problemas con Eclipse Mars en Ubuntu 16.04, en plan no te abre bien las preferencias, no hace conexiones GIT… no te desesperes más.

Por lo visto hay un error con al versión de GTK+3.

Para empezar, abre un terminal y escribe el siguiente comando:

export SWT_GTK3=0

Si te ha funcionado, puedes hacer una modificación persistente, ya que la anterior era sólo temporal. En la carpeta raíz de eclipse, edita el archivo eclipse.ini. Inserta las 2 siguientes líneas:

--launcher.GTK_version
2

Insértalas justo antes de esta línea:

--launcher.appendVmargs

Con esto ya debería funcionar correctamente 🙂


Fuente askubuntu.com

Anuncios